]> Frank Brehm's Git Trees - portage.git/commitdiff
Bugfixingg für kde-base/artsplugin-xine wegen neuer xine-lib
authorFrank Brehm <frank@brehm-online.com>
Fri, 15 Feb 2008 08:52:49 +0000 (08:52 +0000)
committerFrank Brehm <frank@brehm-online.com>
Fri, 15 Feb 2008 08:52:49 +0000 (08:52 +0000)
git-svn-id: http://svn.brehm-online.com/svn/portage@52 18afd0d2-9f2f-0410-a0ac-b8d70fd81a6b

kde-base/artsplugin-xine/Manifest [new file with mode: 0644]
kde-base/artsplugin-xine/artsplugin-xine-3.5.8-r1.ebuild [new file with mode: 0644]
kde-base/artsplugin-xine/files/new-xine-lib.patch [new file with mode: 0644]

diff --git a/kde-base/artsplugin-xine/Manifest b/kde-base/artsplugin-xine/Manifest
new file mode 100644 (file)
index 0000000..00821c3
--- /dev/null
@@ -0,0 +1,3 @@
+AUX new-xine-lib.patch 1014 RMD160 9cb114e1e346e71365f3f1662256f028d1394ad4 SHA1 9b3492136873bf5a76c862c52baaf4595ee48b16 SHA256 0b7fac089c362096afea9a99c53bcd3b2c27910ecb8bc41d7f913d445628b0e0
+DIST kdemultimedia-3.5.8.tar.bz2 6316739 RMD160 5fcb8d282e2d49baca4daa9fb4e24b5216df92ee SHA1 fd70cf7f7378653e92c03fa0b9d9a5368451632c SHA256 07fc79e38bd7d50a8e2b9910a5d78ef565557b2a746b31d5d440829e9f05b0c1
+EBUILD artsplugin-xine-3.5.8-r1.ebuild 582 RMD160 2d5d68b885b2165afd4c55eb36d45ebf8a7c151e SHA1 8aff8bd97e789eeaf0a52eb53fcbfbd9cf368b05 SHA256 7a637aa714e8acd38da836f52b399ff01f111ac9111acebe3b9f41817470a3e4
diff --git a/kde-base/artsplugin-xine/artsplugin-xine-3.5.8-r1.ebuild b/kde-base/artsplugin-xine/artsplugin-xine-3.5.8-r1.ebuild
new file mode 100644 (file)
index 0000000..77da409
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-xine/artsplugin-xine-3.5.8.ebuild,v 1.6 2008/01/31 15:31:05 ranger Exp $
+
+ARTS_REQUIRED="yes"
+KMNAME=kdemultimedia
+KMMODULE=xine_artsplugin
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="arts xine plugin"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+DEPEND=">=media-libs/xine-lib-1.0"
+
+src_unpack() {
+       kde-meta_src_unpack
+       cd ${S}
+       epatch "${FILESDIR}/new-xine-lib.patch"
+}
+
diff --git a/kde-base/artsplugin-xine/files/new-xine-lib.patch b/kde-base/artsplugin-xine/files/new-xine-lib.patch
new file mode 100644 (file)
index 0000000..54c6c00
--- /dev/null
@@ -0,0 +1,17 @@
+--- xine_artsplugin/configure.in.in.orig       2005-09-10 10:20:09.000000000 +0200
++++ xine_artsplugin/configure.in.in    2008-02-15 09:39:43.000000000 +0100
+@@ -69,11 +69,11 @@
+       XINE_CFLAGS=`$XINE_CONFIG $xine_config_args --cflags`
+       XINE_LIBS=`$XINE_CONFIG $xine_config_args --libs`
+       xine_config_major_version=`$XINE_CONFIG $xine_config_args --version | \
+-             sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++             cut -d'.' -f 1`
+       xine_config_minor_version=`$XINE_CONFIG $xine_config_args --version | \
+-             sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++             cut -d'.' -f 2`
+       xine_config_sub_version=`$XINE_CONFIG $xine_config_args --version | \
+-             sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++             cut -d'.' -f 3`
+       xine_script_dir=`$XINE_CONFIG $xine_config_args --scriptdir`
+       xine_plugin_dir=`$XINE_CONFIG $xine_config_args --plugindir`
+       xine_locale_dir=`$XINE_CONFIG $xine_config_args --localedir`