]> Frank Brehm's Git Trees - portage.git/commitdiff
Neues Ebuild desktopnova
authorFrank Brehm <frank@brehm-online.com>
Tue, 23 Mar 2010 20:32:22 +0000 (20:32 +0000)
committerFrank Brehm <frank@brehm-online.com>
Tue, 23 Mar 2010 20:32:22 +0000 (20:32 +0000)
git-svn-id: http://svn.brehm-online.com/svn/portage@83 18afd0d2-9f2f-0410-a0ac-b8d70fd81a6b

x11-apps/desktopnova/Manifest [new file with mode: 0644]
x11-apps/desktopnova/desktopnova-0.7.4.ebuild [new file with mode: 0644]

diff --git a/x11-apps/desktopnova/Manifest b/x11-apps/desktopnova/Manifest
new file mode 100644 (file)
index 0000000..310164b
--- /dev/null
@@ -0,0 +1,2 @@
+DIST desktopnova-0.7.4.tar.gz 108148 RMD160 070ce0d34591ecdf3a05cbd580ef8b44d9691848 SHA1 e030b0c6f2b8f86740bca5bc01aba621af964023 SHA256 5d81ec4762194362c2977d51fc9b492433afe0ffc1b62c7ad17b029f63ec9125
+EBUILD desktopnova-0.7.4.ebuild 1185 RMD160 b851c72e61ed59519ae0f7b2a1407577a5932d58 SHA1 c9c854404826bd9077afec4dbef6c4836d8a12da SHA256 638f0370cc2eb10086a963c8b8a6e0f615a51203ba7080f8e063bcbe4421ca0b
diff --git a/x11-apps/desktopnova/desktopnova-0.7.4.ebuild b/x11-apps/desktopnova/desktopnova-0.7.4.ebuild
new file mode 100644 (file)
index 0000000..a0c1afe
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gcalctool/gcalctool-5.28.2.ebuild,v 1.2 2010/01/07 21:37:49 fauli Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils distutils
+
+DESCRIPTION="It changes your desktop wallpaper automatically in a Gnome and Xfce based desktop"
+HOMEPAGE="http://sites.google.com/site/haliner/desktopnova/"
+SRC_URI="http://launchpad.net/gwallpapers/0.7/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="gnome xfce"
+
+RDEPEND=">=sys-devel/gcc-4
+       >=sys-devel/gettext-0.17
+       >=sys-devel/make-3.81
+       >=dev-util/cmake-2.6.4
+       >=dev-lang/python-2.6
+       >=x11-libs/gtk+-2.14.0
+       >=dev-libs/glib-2
+       gnome? ( >=gnome-base/gconf-2 )
+       xfce? ( >=xfce-base/xfconf-4 )
+       >=dev-libs/libxml2-2.7
+       >=dev-libs/dbus-glib-0.76"
+
+DOCS="ABOUT-NLS AUTHORS ChangeLog* COPYING INSTALL LICENSE NEWS README TODO TRANSLATORS"
+
+src_configure() {
+       enable_cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_test() {
+       LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
+}
+
+src_install() {
+       cmake-utils_src_install
+}
+
+