]> Frank Brehm's Git Trees - portage.git/commitdiff
Ins richtige Unterverzeichnis verschoben
authorFrank Brehm <frank@brehm-online.com>
Mon, 7 Apr 2008 13:40:53 +0000 (13:40 +0000)
committerFrank Brehm <frank@brehm-online.com>
Mon, 7 Apr 2008 13:40:53 +0000 (13:40 +0000)
git-svn-id: http://svn.brehm-online.com/svn/portage@55 18afd0d2-9f2f-0410-a0ac-b8d70fd81a6b

ndoutils/Manifest [deleted file]
ndoutils/files/ndo2db.init [deleted file]
ndoutils/ndoutils-1.4_beta7-r1.ebuild [deleted file]
net-analyzer/ndoutils/Manifest [new file with mode: 0644]
net-analyzer/ndoutils/files/ndo2db.init [new file with mode: 0755]
net-analyzer/ndoutils/ndoutils-1.4_beta7-r1.ebuild [new file with mode: 0644]

diff --git a/ndoutils/Manifest b/ndoutils/Manifest
deleted file mode 100644 (file)
index 6365a61..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX ndo2db.init 547 RMD160 f463c156a0577585809d8a01470b042d535f4a98 SHA1 d04b6030285d415cb8b032a27816401bd2bc542b SHA256 46d482286bc19e3cb31a4a3caca1c98fa23282e442729e49d0739f8a254b563c
-DIST ndoutils-1.4b7.tar.gz 1553879 RMD160 a5cb66c59cf20705f54d1c8dda5ed244daf9b2fc SHA1 9b02fda9a612f07d6aa353c9a4a01be121094224 SHA256 76053576fa55f0231917733fc8e7a95d93e013cdb693fadbd8e8a7aa9ac8162c
-EBUILD ndoutils-1.4_beta7-r1.ebuild 2104 RMD160 8a314e41c32acab4a55718899b9c15bcb6742df6 SHA1 b17eff2fe42e526de2002ef900f6c5327442b1c7 SHA256 f2179c5aa6fbf8811cb5b8d50ac61e17c3ee9b88c14293e052159b18723c7366
diff --git a/ndoutils/files/ndo2db.init b/ndoutils/files/ndo2db.init
deleted file mode 100755 (executable)
index d2864be..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndoutils/files/ndo2db.init,v 1.1 2007/07/01 08:29:56 dertobi123 Exp $
-
-depends() {
-       before nagios
-       need mysql
-}
-
-start() {
-       ebegin "Starting ndo2db"
-       start-stop-daemon --start --quiet --exec /usr/nagios/bin/ndo2db-2x \
-       -- -c /etc/nagios/ndo2db.cfg
-       eend $?
-}
-
-stop() {
-       ebegin "Stopping ndo2db"
-       start-stop-daemon --stop --quiet --exec /usr/nagios/bin/ndo2db-2x
-       eend $?
-}
diff --git a/ndoutils/ndoutils-1.4_beta7-r1.ebuild b/ndoutils/ndoutils-1.4_beta7-r1.ebuild
deleted file mode 100644 (file)
index efa91c0..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndoutils/ndoutils-1.4_beta7.ebuild,v 1.1 2008/03/08 21:21:36 dertobi123 Exp $
-
-inherit eutils
-
-MY_P=${P/_beta/b}
-
-DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
-HOMEPAGE="http://www.nagios.org"
-SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-db/mysql"
-RDEPEND="${DEPEND}
-       >=net-analyzer/nagios-core-2.7"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       enewgroup nagios
-       enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
-
-src_compile() {
-       econf \
-               --prefix=/usr/nagios \
-               --sysconfdir=/etc/nagios \
-               --enable-mysql \
-               --disable-pgsql || die "econf failed"
-
-       emake || die "emake failed"
-}
-
-src_install() {
-       dodir /usr/nagios/bin
-       cp ${S}/src/{file2sock,log2ndo,ndo2db-2x,ndo2db-3x,ndomod-2x.o,ndomod-3x.o,sockdebug} ${D}/usr/nagios/bin
-
-       dodir /usr/nagios/share/
-       cp -R ${S}/db ${D}/usr/nagios/share
-
-       chown -R root:nagios ${D}/usr/nagios || die "Failed chown of ${D}/usr/nagios"
-       chmod 750 ${D}/usr/nagios/bin/{file2sock,log2ndo,ndo2db-2x,ndo2db-3x,ndomod-2x.o,ndomod-3x.o,sockdebug} || "Failed chmod"
-
-       dodoc README REQUIREMENTS TODO UPGRADING Changelog "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
-
-cat << EOF > "${T}"/55-ndoutils-revdep
-SEARCH_DIRS="/usr/nagios/bin"
-EOF
-
-       sed -i s:socket_name=/usr/local/nagios/var/ndo.sock:socket_name=/var/nagios/ndo.sock:g ${S}/config/ndo2db.cfg
-
-       insinto /etc/revdep-rebuild
-       doins "${T}"/55-ndoutils-revdep
-
-       insinto /etc/nagios
-       doins ${S}/config/ndo2db.cfg
-       doins ${S}/config/ndomod.cfg
-
-       newinitd ${FILESDIR}/ndo2db.init ndo2db
-}
-
-pkg_postinst() {
-       elog "To include NDO in your Nagios setup you'll need to activate the NDO broker module"
-       elog "in /etc/nagios/nagios.cfg:"
-       elog "\tbroker_module=/usr/nagios/bin/ndomod-2x.o config_file=/etc/nagios/ndomod.cfg"
-       elog "\t\tor"
-       elog "\tbroker_module=/usr/nagios/bin/ndomod-3x.o config_file=/etc/nagios/ndomod.cfg"
-       elog "\t\trespectively."
-}
diff --git a/net-analyzer/ndoutils/Manifest b/net-analyzer/ndoutils/Manifest
new file mode 100644 (file)
index 0000000..6365a61
--- /dev/null
@@ -0,0 +1,3 @@
+AUX ndo2db.init 547 RMD160 f463c156a0577585809d8a01470b042d535f4a98 SHA1 d04b6030285d415cb8b032a27816401bd2bc542b SHA256 46d482286bc19e3cb31a4a3caca1c98fa23282e442729e49d0739f8a254b563c
+DIST ndoutils-1.4b7.tar.gz 1553879 RMD160 a5cb66c59cf20705f54d1c8dda5ed244daf9b2fc SHA1 9b02fda9a612f07d6aa353c9a4a01be121094224 SHA256 76053576fa55f0231917733fc8e7a95d93e013cdb693fadbd8e8a7aa9ac8162c
+EBUILD ndoutils-1.4_beta7-r1.ebuild 2104 RMD160 8a314e41c32acab4a55718899b9c15bcb6742df6 SHA1 b17eff2fe42e526de2002ef900f6c5327442b1c7 SHA256 f2179c5aa6fbf8811cb5b8d50ac61e17c3ee9b88c14293e052159b18723c7366
diff --git a/net-analyzer/ndoutils/files/ndo2db.init b/net-analyzer/ndoutils/files/ndo2db.init
new file mode 100755 (executable)
index 0000000..d2864be
--- /dev/null
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndoutils/files/ndo2db.init,v 1.1 2007/07/01 08:29:56 dertobi123 Exp $
+
+depends() {
+       before nagios
+       need mysql
+}
+
+start() {
+       ebegin "Starting ndo2db"
+       start-stop-daemon --start --quiet --exec /usr/nagios/bin/ndo2db-2x \
+       -- -c /etc/nagios/ndo2db.cfg
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping ndo2db"
+       start-stop-daemon --stop --quiet --exec /usr/nagios/bin/ndo2db-2x
+       eend $?
+}
diff --git a/net-analyzer/ndoutils/ndoutils-1.4_beta7-r1.ebuild b/net-analyzer/ndoutils/ndoutils-1.4_beta7-r1.ebuild
new file mode 100644 (file)
index 0000000..efa91c0
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndoutils/ndoutils-1.4_beta7.ebuild,v 1.1 2008/03/08 21:21:36 dertobi123 Exp $
+
+inherit eutils
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-db/mysql"
+RDEPEND="${DEPEND}
+       >=net-analyzer/nagios-core-2.7"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       enewgroup nagios
+       enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_compile() {
+       econf \
+               --prefix=/usr/nagios \
+               --sysconfdir=/etc/nagios \
+               --enable-mysql \
+               --disable-pgsql || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       dodir /usr/nagios/bin
+       cp ${S}/src/{file2sock,log2ndo,ndo2db-2x,ndo2db-3x,ndomod-2x.o,ndomod-3x.o,sockdebug} ${D}/usr/nagios/bin
+
+       dodir /usr/nagios/share/
+       cp -R ${S}/db ${D}/usr/nagios/share
+
+       chown -R root:nagios ${D}/usr/nagios || die "Failed chown of ${D}/usr/nagios"
+       chmod 750 ${D}/usr/nagios/bin/{file2sock,log2ndo,ndo2db-2x,ndo2db-3x,ndomod-2x.o,ndomod-3x.o,sockdebug} || "Failed chmod"
+
+       dodoc README REQUIREMENTS TODO UPGRADING Changelog "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+cat << EOF > "${T}"/55-ndoutils-revdep
+SEARCH_DIRS="/usr/nagios/bin"
+EOF
+
+       sed -i s:socket_name=/usr/local/nagios/var/ndo.sock:socket_name=/var/nagios/ndo.sock:g ${S}/config/ndo2db.cfg
+
+       insinto /etc/revdep-rebuild
+       doins "${T}"/55-ndoutils-revdep
+
+       insinto /etc/nagios
+       doins ${S}/config/ndo2db.cfg
+       doins ${S}/config/ndomod.cfg
+
+       newinitd ${FILESDIR}/ndo2db.init ndo2db
+}
+
+pkg_postinst() {
+       elog "To include NDO in your Nagios setup you'll need to activate the NDO broker module"
+       elog "in /etc/nagios/nagios.cfg:"
+       elog "\tbroker_module=/usr/nagios/bin/ndomod-2x.o config_file=/etc/nagios/ndomod.cfg"
+       elog "\t\tor"
+       elog "\tbroker_module=/usr/nagios/bin/ndomod-3x.o config_file=/etc/nagios/ndomod.cfg"
+       elog "\t\trespectively."
+}