]> Frank Brehm's Git Trees - portage.git/commitdiff
Added dev-python/nagios-plugin/nagios-plugin-0.4.5.1.ebuild
authorFrank Brehm <frank@brehm-online.com>
Thu, 29 Aug 2013 08:33:11 +0000 (10:33 +0200)
committerFrank Brehm <frank@brehm-online.com>
Thu, 29 Aug 2013 08:33:11 +0000 (10:33 +0200)
dev-python/nagios-plugin/Manifest
dev-python/nagios-plugin/nagios-plugin-0.4.5.1.ebuild [new file with mode: 0644]

index e69141235deebe8b3092d2612482ac9d11a11463..370ef465e4e5d421abfad4404b43956ffbf1012e 100644 (file)
@@ -1,3 +1,4 @@
 EBUILD nagios-plugin-0.4.2.2.ebuild 1469 SHA256 18c6fd1dabcfe8bf517b4da5d1876425fd4603e50f27d20d07b9407a798937f5 SHA512 3e964e60ad9fcdb0072ccca11299b1617279dd542243413438ecd132c2a21de11b30324cf39d684bb530b71e7bdb3453644cb8c33f774b8241c2862e364fc067 WHIRLPOOL 9945a389b8dab7c4f1f76d0501d63694904204f96f54e5f87d0aa721a2a4c67ee6f5180eea2383cdbe1b84c476582e91f920b42564694c71bdc1d0255b1a7a0d
 EBUILD nagios-plugin-0.4.4.2.ebuild 1472 SHA256 36a102d4ff1adfd5c685150a534554042f2e02ba3e3228e368d49fcf7ed7787d SHA512 37fd7acbb258988db7b766f5a90b2fb151504d43af13cf4096469a8bda5320541b5a1240acdc8710704bf9d81f84b6a6e14e2e5e249c52aba353cf0353e86ea9 WHIRLPOOL da67ee6647e1e0550ab8ff44148698fb27a4f8375c45d087f621fa5b8632268c0ed72b27161ff682fd7ad84575be0b5a3fcadff2c11e3b4a25fa5c12d3b723d2
+EBUILD nagios-plugin-0.4.5.1.ebuild 1472 SHA256 36a102d4ff1adfd5c685150a534554042f2e02ba3e3228e368d49fcf7ed7787d SHA512 37fd7acbb258988db7b766f5a90b2fb151504d43af13cf4096469a8bda5320541b5a1240acdc8710704bf9d81f84b6a6e14e2e5e249c52aba353cf0353e86ea9 WHIRLPOOL da67ee6647e1e0550ab8ff44148698fb27a4f8375c45d087f621fa5b8632268c0ed72b27161ff682fd7ad84575be0b5a3fcadff2c11e3b4a25fa5c12d3b723d2
 EBUILD nagios-plugin-9999.ebuild 1372 SHA256 648bfef04e987ceb74b64d2188e5ca8aa0981f09deaffdf9550d00d4525a1493 SHA512 d247599e1c2cefefcd87af8888cd9f67c3571b941e61a857677990434709efa49e43ad05f0ab78e05a81e17c64d3c0b89bd834efa287b87621e9ce26f202d4af WHIRLPOOL 332a2a4dc87b4da17f22e76a2954efd9b3bb0fa785b3fee6fc38ddc69a8f8cd0e94c1ff76817175c08376e334d1569a5d34835dc667e2d3aef55048875d5adf9
diff --git a/dev-python/nagios-plugin/nagios-plugin-0.4.5.1.ebuild b/dev-python/nagios-plugin/nagios-plugin-0.4.5.1.ebuild
new file mode 100644 (file)
index 0000000..2b516f6
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Python modules streamline writing Nagios plugins."
+HOMEPAGE="http://git.profitbricks.localdomain/gitweb/?p=python/nagios-plugin;a=summary"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/nagios-plugin.git"
+
+inherit git-2 distutils user python versionator
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc"
+PYTHON_DEPEND="2::2.7"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT=$(replace_version_separator 3 '-')
+
+DOCS="debian/changelog README.txt"
+
+RDEPEND="
+       virtual/python-argparse
+"
+DEPEND="
+       ${RDEPEND}
+       doc? (  dev-python/epydoc 
+                       dev-python/docutils
+       )
+"
+
+pkg_setup() {
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+       python_set_active_version 2
+       python_pkg_setup
+}
+
+src_install() {
+       distutils_src_install
+       #python_clean_installation_image
+
+       if use doc; then
+               einfo "Installing documentation ..."
+               dodir "/usr/share/doc/${PF}"
+               dodir "/usr/share/doc/${PF}/html"
+               dodir "/usr/share/doc/${PF}/pdf"
+
+               einfo "Creating epydoc html documentation"
+               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/nagios" || ewarn "Could not create epydoc html documentation"
+               einfo "Creating epydoc pdf documentation"
+               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/nagios" || ewarn "Could not create epydoc pdf documentation"
+
+       fi
+
+}
+
+pkg_postinst() {
+       python_mod_optimize nagios
+}
+
+pkg_postrm () {
+    python_mod_cleanup nagios
+}
+