]> Frank Brehm's Git Trees - portage.git/commitdiff
Added dev-python/pb-dbhandler/pb-dbhandler-0.4.1.1.ebuild
authorFrank Brehm <frank@brehm-online.com>
Fri, 14 Jun 2013 09:20:52 +0000 (11:20 +0200)
committerFrank Brehm <frank@brehm-online.com>
Fri, 14 Jun 2013 09:20:52 +0000 (11:20 +0200)
dev-python/pb-dbhandler/Manifest [new file with mode: 0644]
dev-python/pb-dbhandler/pb-dbhandler-0.4.1.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pb-dbhandler/Manifest b/dev-python/pb-dbhandler/Manifest
new file mode 100644 (file)
index 0000000..ce1a006
--- /dev/null
@@ -0,0 +1 @@
+EBUILD pb-dbhandler-0.4.1.1.ebuild 1697 SHA256 a7c3026cf204b770f9053df38e84d6b8ad3440e4d69541539ac2fa55ab8c5a4d SHA512 a3c59658be4a3a8ac560ff615f03e4e4f067142e8aa594b9bc05d08c934109ef82f749e9516f078085d4d6c8c6953ca337c5f9492d4014927b43c63c92bc06ee WHIRLPOOL 104e733f50022b8bc873fdc925a5ffcfed697ceadab0f8acf3363ae05aba3c65e4b862c558c0738b7e46fb9a33783a2cc2174e282f879dd4adf607e1526f90fb
diff --git a/dev-python/pb-dbhandler/pb-dbhandler-0.4.1.1.ebuild b/dev-python/pb-dbhandler/pb-dbhandler-0.4.1.1.ebuild
new file mode 100644 (file)
index 0000000..0b82cab
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Python modules for common used classes for access to databases, escpecially to PostrgreSQL."
+HOMEPAGE="https://github.com/fbrehm/py_pb_dbhandler"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/py_pb_dbhandler.git"
+
+inherit git-2 distutils user python versionator
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc nls"
+PYTHON_DEPEND="2::2.7"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT=$(replace_version_separator 3 '-')
+
+DOCS="debian/changelog README.txt"
+
+RDEPEND="
+       dev-python/psycopg
+       >=dev-python/pb-base-0.3.10
+       nls? ( virtual/libintl )
+"
+DEPEND="
+       ${RDEPEND}
+       doc? (  dev-python/epydoc 
+                       dev-python/docutils
+                       dev-texlive/texlive-latexextra
+       )
+       nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+
+       python_set_active_version 2
+       python_pkg_setup
+}
+
+src_install() {
+       distutils_src_install
+       #python_clean_installation_image
+
+       if use doc; then
+               einfo "Installing documentation ..."
+               dodir "/usr/share/doc/${PF}"
+               dodir "/usr/share/doc/${PF}/html"
+               dodir "/usr/share/doc/${PF}/pdf"
+
+               einfo "Creating epydoc html documentation"
+               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/src/pb_dbhandler" || ewarn "Could not create epydoc html documentation"
+               einfo "Creating epydoc pdf documentation"
+               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/src/pb_dbhandler" || ewarn "Could not create epydoc pdf documentation"
+
+       fi
+
+       if use nls; then
+               (cd "${S}/po" && make DESTDIR="${ED}" install)
+       fi
+
+}
+
+pkg_postinst() {
+       python_mod_optimize pb_base
+}
+
+pkg_postrm () {
+    python_mod_cleanup pb_base
+}
+
+