]> Frank Brehm's Git Trees - portage.git/commitdiff
Added dev-python/pb-base/pb-base-0.5.0.2.ebuild
authorFrank Brehm <frank@brehm-online.com>
Fri, 13 Sep 2013 19:59:37 +0000 (21:59 +0200)
committerFrank Brehm <frank@brehm-online.com>
Fri, 13 Sep 2013 19:59:37 +0000 (21:59 +0200)
dev-python/pb-base/Manifest
dev-python/pb-base/pb-base-0.5.0.2.ebuild [new file with mode: 0644]

index 7f31db29273c7a7807d2826bebb2c6e548fb1cb2..37116d8f21b19da31fcd34a417de6775956ba007 100644 (file)
@@ -1,2 +1,3 @@
 EBUILD pb-base-0.4.10.2.ebuild 1805 SHA256 a32d02da651ce7b254d53519ab17c80735d4d95f7bbf37bd5898a6f490659f03 SHA512 0b86d0430b027b9cd55447c14d8d888c5c088590d30572d4684cf97367555c82943d097f71d31ce81f459254e8b9c2b81d86fbf3690eb3e07d48082db677199f WHIRLPOOL 3fbd3d9a04d828c9f8261d9aacfba521f5b26cbc954ee6e2fed1d5779a11c1a6f5df1ca6be622c21090420a055dc24068c8be61b4af60489345e2a84d0c7b04b
 EBUILD pb-base-0.4.11.1.ebuild 1805 SHA256 a32d02da651ce7b254d53519ab17c80735d4d95f7bbf37bd5898a6f490659f03 SHA512 0b86d0430b027b9cd55447c14d8d888c5c088590d30572d4684cf97367555c82943d097f71d31ce81f459254e8b9c2b81d86fbf3690eb3e07d48082db677199f WHIRLPOOL 3fbd3d9a04d828c9f8261d9aacfba521f5b26cbc954ee6e2fed1d5779a11c1a6f5df1ca6be622c21090420a055dc24068c8be61b4af60489345e2a84d0c7b04b
+EBUILD pb-base-0.5.0.2.ebuild 1849 SHA256 3acbd89a9afa4d0fd39c03b171d21e2eba967295f7a814cea763017a8dd32365 SHA512 589eacd6f9c9a01824cecf7586c7eebbb8a71e9e69552da7dd3461ae5105d77256be01a3ebfbd43cb4dd36a2aac51f987c7c5598a6e99be95a532366c86e5dcb WHIRLPOOL d0320c200c1e57594a572a8cdaeb382f1e2728e87d8f5b7157fccffe7d34789031f478ad3a663c1ca0b5bdfb05601f51827995dbd360c710f2987a5d935f356b
diff --git a/dev-python/pb-base/pb-base-0.5.0.2.ebuild b/dev-python/pb-base/pb-base-0.5.0.2.ebuild
new file mode 100644 (file)
index 0000000..2951627
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Python modules for common used objects, error classes and functions."
+HOMEPAGE="https://github.com/fbrehm/py_pb_base"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/py_pb_base.git"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit git-2 distutils-r1 user versionator
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc nls"
+PYTHON_DEPEND="2::2.7"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT=$(replace_version_separator 3 '-')
+
+DOCS="debian/changelog README.txt"
+
+RDEPEND="
+       virtual/python-argparse
+       dev-python/configobj
+       >=dev-python/pb-logging-0.2.7
+       nls? ( virtual/libintl )
+"
+DEPEND="
+       ${RDEPEND}
+       doc? (  dev-python/epydoc 
+                       dev-python/docutils
+                       dev-texlive/texlive-latexextra
+       )
+       nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+
+       elog "Start setup package ..."
+       python_set_active_version 2
+       python_pkg_setup
+}
+
+src_compile() {
+       elog "Start compiling package ..."
+       distutils_src_compile
+       if use nls; then
+               make -C ${S}/po
+       fi
+}
+
+src_install() {
+       distutils_src_install
+       #python_clean_installation_image
+
+       if use doc; then
+               einfo "Installing documentation ..."
+               dodir "/usr/share/doc/${PF}"
+               dodir "/usr/share/doc/${PF}/html"
+               dodir "/usr/share/doc/${PF}/pdf"
+
+               einfo "Creating epydoc html documentation"
+               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/pb_base" || ewarn "Could not create epydoc html documentation"
+               einfo "Creating epydoc pdf documentation"
+               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/pb_base" || ewarn "Could not create epydoc pdf documentation"
+
+       fi
+
+       if use nls; then
+               make -C ${S}/po DESTDIR="${ED}" install
+       fi
+
+}
+
+pkg_postinst() {
+       python_mod_optimize pb_base
+}
+
+pkg_postrm () {
+    python_mod_cleanup pb_base
+}
+
+