]> Frank Brehm's Git Trees - portage.git/commitdiff
Cleanup of dev-python/pb-logging
authorFrank Brehm <frank@brehm-online.com>
Wed, 9 Jul 2014 21:33:58 +0000 (23:33 +0200)
committerFrank Brehm <frank@brehm-online.com>
Wed, 9 Jul 2014 21:33:58 +0000 (23:33 +0200)
dev-python/pb-logging/Manifest
dev-python/pb-logging/pb-logging-0.4.1.3-r3.ebuild [new file with mode: 0644]
dev-python/pb-logging/pb-logging-0.4.1.3.ebuild [deleted file]

index 765334ed13275f42f00e209de3c4043a5b0c8fd8..0bf255eba240e942f4c08d9f430fa86c6684207b 100644 (file)
@@ -1,3 +1,3 @@
 EBUILD pb-logging-0.3.2.1.ebuild 1540 SHA256 65fb300b2d90dc0b0d1db2a0cbac35acc94c4e5dae0ebf41d90cd4d697f40248 SHA512 8395a3d940110d6af0a805dde3c7a467b61976b44e70e195e20b3703ce9ec95fd8946abbed0f17dabed131c74452cf04e039faab22066eb161a5b11502facf52 WHIRLPOOL e2208db4b1c1965a63f13ec002ee7bc6cb2707805a69784dc45ddd15b01344efeaa2344edf48bb5ab284f73e59f64a58884f98b45029fa6520d85d8488cffc4f
 EBUILD pb-logging-0.4.0.1.ebuild 1333 SHA256 019e5eaff5030bd6e55dd060a8ec28644d2cb01a3139f561c0792384a83d66b6 SHA512 3f8ad2b0a20b7e8bc62ab9763527bb50a753bee7010ae5bc1f7202d1789096204c62d4612dcf31fefce14d9de1fedcafe7b66d0c17346f5f45211ed29a70bf60 WHIRLPOOL f5266db7db22d5a8e7511f44fb23fd38c0bb36bdd31e07ecb7b490285f1c303c9b682409486e0d01914b6342b399436012a67ca005b092b2d556635fb81ae134
-EBUILD pb-logging-0.4.1.3.ebuild 1367 SHA256 9abd7d7ad6d0ad0dc569dcdf0dcea69652b0e8170b6d0e1c7f2d77bd0a01eaed SHA512 6e34d15c379d8cae33495a08385eb87df510a6400e4daf125c06e04be64de2e01b18f577e2751e94f3af03b7617edfc54aca5012510811a892d5ea69c8f15dc2 WHIRLPOOL 81e46e719e4cce0f658e0c42ee8ff41c28cee7f573325733c7cdbf366bef36f1874a411ed946acb10e49efb65eb3419d3c817ab903fcf59f64f7b2bc649c9390
+EBUILD pb-logging-0.4.1.3-r3.ebuild 1337 SHA256 930af4b9facb0e4139d82ea8747c64353ebf691d69e1f3a5c005e6709b1a19f4 SHA512 84bf75bd2797a280c64ad03e6f688d7126461bd2127f6da8a0910a35f6b3cc6074116ec1a659280a6560738cbd0fc1b2632c5ae9018e311e4c46d989c33189f7 WHIRLPOOL a099427ca68422ddcebe1604332b46bef2fec5d04b221c8ae00dc718ab0a4404499ca320b22810ffc6950ef36e7f46fd48e6a8626debffedeb0835c79b049a6c
diff --git a/dev-python/pb-logging/pb-logging-0.4.1.3-r3.ebuild b/dev-python/pb-logging/pb-logging-0.4.1.3-r3.ebuild
new file mode 100644 (file)
index 0000000..476cd21
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy2_0 )
+
+DESCRIPTION="Python modules to extend the logging mechanism in Python."
+HOMEPAGE="https://github.com/fbrehm/py_pb_logging"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/py_pb_logging.git"
+
+inherit git-2 distutils-r1 user versionator
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT=$(replace_version_separator 3 '-')
+
+DOCS="debian/changelog README.txt"
+
+RDEPEND=""
+DEPEND="
+       ${RDEPEND}
+       doc? (  dev-python/epydoc
+                       dev-python/docutils
+       )
+"
+
+src_prepare() {
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+       distutils-r1_src_prepare
+}
+
+src_install() {
+
+       distutils-r1_src_install
+
+       if use doc; then
+               einfo "Installing documentation ..."
+               dodir "/usr/share/doc/${PF}"
+               dodir "/usr/share/doc/${PF}/html"
+               dodir "/usr/share/doc/${PF}/pdf"
+
+               einfo "Creating epydoc html documentation"
+               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/pb_logging" || ewarn "Could not create epydoc html documentation"
+               einfo "Creating epydoc pdf documentation"
+               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/pb_logging" || ewarn "Could not create epydoc pdf documentation"
+
+       fi
+
+}
+
+# vim: filetype=ebuild ts=4 sw=4
diff --git a/dev-python/pb-logging/pb-logging-0.4.1.3.ebuild b/dev-python/pb-logging/pb-logging-0.4.1.3.ebuild
deleted file mode 100644 (file)
index de234f0..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy2_0 )
-
-DESCRIPTION="Python modules to extend the logging mechanism in Python."
-HOMEPAGE="https://github.com/fbrehm/py_pb_logging"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/fbrehm/py_pb_logging.git"
-
-inherit git-2 distutils-r1 user versionator
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-EGIT_BRANCH="master"
-EGIT_COMMIT=$(replace_version_separator 3 '-')
-
-DOCS="debian/changelog README.txt"
-
-RDEPEND="
-       virtual/python-argparse
-"
-DEPEND="
-       ${RDEPEND}
-       doc? (  dev-python/epydoc
-                       dev-python/docutils
-       )
-"
-
-src_prepare() {
-       elog "Used GIT tag: '${EGIT_COMMIT}'."
-       distutils-r1_src_prepare
-}
-
-src_install() {
-
-       distutils-r1_src_install
-
-       if use doc; then
-               einfo "Installing documentation ..."
-               dodir "/usr/share/doc/${PF}"
-               dodir "/usr/share/doc/${PF}/html"
-               dodir "/usr/share/doc/${PF}/pdf"
-
-               einfo "Creating epydoc html documentation"
-               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/pb_logging" || ewarn "Could not create epydoc html documentation"
-               einfo "Creating epydoc pdf documentation"
-               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/pb_logging" || ewarn "Could not create epydoc pdf documentation"
-
-       fi
-
-}
-
-# vim: filetype=ebuild ts=4 sw=4