]> Frank Brehm's Git Trees - portage.git/commitdiff
Added dev-python/pb-logging/pb-logging-0.3.2.1.ebuild
authorFrank Brehm <frank@brehm-online.com>
Fri, 14 Jun 2013 08:54:19 +0000 (10:54 +0200)
committerFrank Brehm <frank@brehm-online.com>
Fri, 14 Jun 2013 08:54:19 +0000 (10:54 +0200)
dev-python/pb-logging/Manifest [new file with mode: 0644]
dev-python/pb-logging/pb-logging-0.3.2.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pb-logging/Manifest b/dev-python/pb-logging/Manifest
new file mode 100644 (file)
index 0000000..4daa4f2
--- /dev/null
@@ -0,0 +1 @@
+EBUILD pb-logging-0.3.2.1.ebuild 1540 SHA256 65fb300b2d90dc0b0d1db2a0cbac35acc94c4e5dae0ebf41d90cd4d697f40248 SHA512 8395a3d940110d6af0a805dde3c7a467b61976b44e70e195e20b3703ce9ec95fd8946abbed0f17dabed131c74452cf04e039faab22066eb161a5b11502facf52 WHIRLPOOL e2208db4b1c1965a63f13ec002ee7bc6cb2707805a69784dc45ddd15b01344efeaa2344edf48bb5ab284f73e59f64a58884f98b45029fa6520d85d8488cffc4f
diff --git a/dev-python/pb-logging/pb-logging-0.3.2.1.ebuild b/dev-python/pb-logging/pb-logging-0.3.2.1.ebuild
new file mode 100644 (file)
index 0000000..f2a3115
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+
+DESCRIPTION="Python modules to extend the logging mechanism in Python."
+HOMEPAGE="https://github.com/fbrehm/py_pb_logging"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/py_pb_logging.git"
+
+inherit git-2 distutils user python versionator
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+PYTHON_DEPEND="2::2.7"
+
+EGIT_BRANCH="master"
+EGIT_COMMIT=$(replace_version_separator 3 '-')
+
+DOCS="debian/changelog README.txt"
+
+RDEPEND="
+       virtual/python-argparse
+"
+DEPEND="
+       ${RDEPEND}
+       doc? (  dev-python/epydoc 
+                       dev-python/docutils
+                       dev-texlive/texlive-latexextra
+       )
+"
+
+pkg_setup() {
+       python_set_active_version 2
+       python_pkg_setup
+}
+
+src_prepare() {
+       elog "Used GIT tag: '${EGIT_COMMIT}'."
+       distutils_src_prepare
+}
+
+src_install() {
+       distutils_src_install
+       #python_clean_installation_image
+
+       if use doc; then
+               einfo "Installing documentation ..."
+               dodir "/usr/share/doc/${PF}"
+               dodir "/usr/share/doc/${PF}/html"
+               dodir "/usr/share/doc/${PF}/pdf"
+
+               einfo "Creating epydoc html documentation"
+               epydoc --html -v -o "${ED}/usr/share/doc/${PF}/html" "${S}/pb_logging" || ewarn "Could not create epydoc html documentation"
+               einfo "Creating epydoc pdf documentation"
+               epydoc --pdf -o "${ED}/usr/share/doc/${PF}/pdf" "${S}/pb_logging" || ewarn "Could not create epydoc pdf documentation"
+
+       fi
+
+}
+
+pkg_postinst() {
+       python_mod_optimize pb_logging
+}
+
+pkg_postrm () {
+    python_mod_cleanup pb_logging
+}
+
+