]> Frank Brehm's Git Trees - portage.git/commitdiff
Added dev-python/configobj/configobj-4.7.3.ebuild
authorFrank Brehm <frank.brehm@profitbricks.com>
Mon, 13 Jan 2014 17:47:57 +0000 (18:47 +0100)
committerFrank Brehm <frank.brehm@profitbricks.com>
Mon, 13 Jan 2014 17:47:57 +0000 (18:47 +0100)
dev-python/configobj/Manifest [new file with mode: 0644]
dev-python/configobj/configobj-4.7.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/configobj/Manifest b/dev-python/configobj/Manifest
new file mode 100644 (file)
index 0000000..fedec9d
--- /dev/null
@@ -0,0 +1 @@
+EBUILD configobj-4.7.3.ebuild 1129 SHA256 5fcb353e2f87070ed4bef52c4b3b89e6d9e035044e0296305b33ac0739ecd5c0 SHA512 745b90ba8353dc898d3ff3afececc2678bcc0392fd88056b714179e5ff0374f29f86fecaf1a0c13693013d368d092609a128dbddc6832d7558e13d536c7d26b3 WHIRLPOOL b93c2a6d4a36fac498d07b82380a3359670a167a01894e8eabe6e18dcb05207743fe344395f95108a96576f32e74351b2e51f2222c326b58d3432143f2869e46
diff --git a/dev-python/configobj/configobj-4.7.3.ebuild b/dev-python/configobj/configobj-4.7.3.ebuild
new file mode 100644 (file)
index 0000000..a340649
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html http://code.google.com/p/configobj/ http://pypi.python.org/pypi/configobj"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/fbrehm/configobj.git"
+
+inherit git-2 distutils-r1 eutils
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+EGIT_BRANCH="develop"
+#EGIT_COMMIT=$(replace_version_separator 3 '-')
+EGIT_COMMIT=${V}
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+#PATCHES=( "${FILESDIR}"/${P}-fix_tests.patch )
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       sed -e "s/ \(doctest\.testmod(.*\)/ sys.exit(\1[0] != 0)/" -i validate.py || die
+}
+
+python_test() {
+       "${PYTHON}" validate.py -v || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use doc; then
+               rm -f docs/BSD*
+               insinto /usr/share/doc/${PF}/html
+               doins -r docs/* || die "doins failed"
+       fi
+}